Advertisement
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Outdated Siri a Chat command bot 1.5.0 Beta 1

Siri is your computerized personal assistant that you can talk to, and run commands.

  1. TrilogiForce
    Offline

    TrilogiForce Ban Evader Banned

    Joined:
    Sep 7, 2013
    Posts:
    228
    Minecraft User:
    TrilogiForce
    yes,only for gamemode and stuff that use it for the user!
  2. Glitchmaster_PE
    Offline

    Glitchmaster_PE Notable Member Plugin Developer

    Joined:
    Aug 31, 2013
    Posts:
    834
    Plugins:
    8
    Minecraft User:
    Glitchmaster_PE
    1. The $user is not needed, I see it used no where in the code

    2. I would recommend using $issuer->sendChat("message"); instead of broadcast
  3. Falk
    Offline

    Falk Staff Member Global Moderator

    Joined:
    Sep 2, 2013
    Posts:
    1,706
    Plugins:
    22
    Minecraft User:
    Falkirknh
    That would probably be better
  4. TrilogiForce
    Offline

    TrilogiForce Ban Evader Banned

    Joined:
    Sep 7, 2013
    Posts:
    228
    Minecraft User:
    TrilogiForce
    i know but i dont know so much about the api so i juts us the basics.
  5. Glitchmaster_PE
    Offline

    Glitchmaster_PE Notable Member Plugin Developer

    Joined:
    Aug 31, 2013
    Posts:
    834
    Plugins:
    8
    Minecraft User:
    Glitchmaster_PE
    Ok, I didn't know much at your stage either :)
  6. Legomite
    Offline

    Legomite Active Member Plugin Developer

    Joined:
    Sep 8, 2013
    Posts:
    470
    Plugins:
    2
    Minecraft User:
    Legomite
  7. edwinyoo44
    Offline

    edwinyoo44 New Member

    Joined:
    Nov 13, 2013
    Posts:
    9
    Minecraft User:
    edwinyoo44
    What is this??
    2013-11-27 13:44:02 [ERROR] A level 8 error happened: "Trying to get property of non-object" in ":eek:\我的資料夾\70105\新增資料夾 (2)\PocketMine-MP\src\API\PluginAPI.php(87) : eval()'d code" at line 1
    2013-11-27 13:44:02 [ERROR] An Unrecovereable has ocurred and the server has Crashed. Creating an Error Dump
    2013-11-27 13:44:02 [ERROR] Please submit the "Error_Dump_Wed_Nov_27-13.44.02-GMT_2013.log" file to the Bug Reporting page. Give as much info as you can.
    2013-11-27 13:44:02 [INFO] Stopping server...
  8. Legomite
    Offline

    Legomite Active Member Plugin Developer

    Joined:
    Sep 8, 2013
    Posts:
    470
    Plugins:
    2
    Minecraft User:
    Legomite
    Did you edit your src? This plugin may not work with the old pocket essentials use the new server software for 7.6. That looks like kevin src. Fix the src and restart the server. This plugin should work now.
    edwinyoo44 likes this.
  9. edwinyoo44
    Offline

    edwinyoo44 New Member

    Joined:
    Nov 13, 2013
    Posts:
    9
    Minecraft User:
    edwinyoo44
    Thanks I go to try it.
    ((Sorry my English is not good :confused:
  10. Legomite
    Offline

    Legomite Active Member Plugin Developer

    Joined:
    Sep 8, 2013
    Posts:
    470
    Plugins:
    2
    Minecraft User:
    Legomite
    Legomite updated Siri with a new update entry:

    MAJOR UPDATE-DOWNLOAD NOW!

    Read the rest of this update entry...
  11. PEMapModder
    Offline

    PEMapModder Notable Member Plugin Developer

    Joined:
    Oct 9, 2013
    Posts:
    7,294
    Plugins:
    11
    Minecraft User:
    PEMapModder
    There is no API 13 or 14...
  12. Falk
    Offline

    Falk Staff Member Global Moderator

    Joined:
    Sep 2, 2013
    Posts:
    1,706
    Plugins:
    22
    Minecraft User:
    Falkirknh
    Current dev build on Main branch uses 13.
  13. Legomite
    Offline

    Legomite Active Member Plugin Developer

    Joined:
    Sep 8, 2013
    Posts:
    470
    Plugins:
    2
    Minecraft User:
    Legomite
    I added support for future updates. :)
  14. PEMapModder
    Offline

    PEMapModder Notable Member Plugin Developer

    Joined:
    Oct 9, 2013
    Posts:
    7,294
    Plugins:
    11
    Minecraft User:
    PEMapModder
    Yes but API 13 won't be in this format of loading plugins.
  15. Legomite
    Offline

    Legomite Active Member Plugin Developer

    Joined:
    Sep 8, 2013
    Posts:
    470
    Plugins:
    2
    Minecraft User:
    Legomite
    Ya, I know. :(
  16. Legomite
    Offline

    Legomite Active Member Plugin Developer

    Joined:
    Sep 8, 2013
    Posts:
    470
    Plugins:
    2
    Minecraft User:
    Legomite
    I'd hate to restart from scratch. The new API don't even make sense to me, 3 files? What the heck is Phar and why is there a folder bundled with a yml?
  17. Legomite
    Offline

    Legomite Active Member Plugin Developer

    Joined:
    Sep 8, 2013
    Posts:
    470
    Plugins:
    2
    Minecraft User:
    Legomite
  18. PEMapModder
    Offline

    PEMapModder Notable Member Plugin Developer

    Joined:
    Oct 9, 2013
    Posts:
    7,294
    Plugins:
    11
    Minecraft User:
    PEMapModder
    Still old API?
    iJoshuaHD likes this.
  19. holler
    Offline

    holler New Member

    Joined:
    Nov 25, 2014
    Posts:
    17
    Minecraft User:
    ShadowsBrofist
    can you please update it to the new API because a lot of new people to minecraft might need it!
  20. iksaku
    Offline

    iksaku Notable Member Plugin Developer

    Joined:
    Sep 2, 2013
    Posts:
    1,130
    Plugins:
    4
    Minecraft User:
    iksaku
    There is no GUI! xD

Share This Page

Advertisement