Advertisement
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[PocketEssentials] Do not upgrade to 1.4.0 before PocketEssentials releases for 1.4.0

Comments in 'Plugin Development' started by VanishedKevin, Nov 23, 2013.

  1. VanishedKevin
    Offline

    VanishedKevin Banned

    Joined:
    Aug 27, 2013
    Posts:
    279
    Minecraft User:
    VanishedKevin
    PMEss 3.5.0 is RELEASED!
    It no longer needs to change SRC! YAY! :D


    [ Get It NOW! ]


    Do *NOT* upgrade to PocketMine_1.4.0 before PocketEssentials releases/ports to PocketMine_1.4.0.

    What will change in PMEss 3.5.0:
    It won't require SRC modify anymore!

    Reasons:
    1: There will be a huge API rewrite and all plugins will not work anymore.
    2: PocketMine doesn't allow to change SRC code anymore.

    When to upgrade to PocketMine 1.4.0 is fine?
    I will try to port all features to PocketMine_1.4.0 in two weeks.
    So keep your eyes on our plugin page until I release a version for PocketMine 1.4.0.
    Last edited: Nov 24, 2013
  2. Glitchmaster_PE
    Offline

    Glitchmaster_PE Notable Member Plugin Developer

    Joined:
    Aug 31, 2013
    Posts:
    834
    Plugins:
    8
    Minecraft User:
    Glitchmaster_PE
    Well, a lot of the functions will change so I would wait till the actual release of 1.4 before you try to update...
  3. VanishedKevin
    Offline

    VanishedKevin Banned

    Joined:
    Aug 27, 2013
    Posts:
    279
    Minecraft User:
    VanishedKevin
    I am talking to the users who use my plugin. XD
  4. Glitchmaster_PE
    Offline

    Glitchmaster_PE Notable Member Plugin Developer

    Joined:
    Aug 31, 2013
    Posts:
    834
    Plugins:
    8
    Minecraft User:
    Glitchmaster_PE
    I know, but when 1.4, a lot of functions like sendChat and stuff will change
  5. 0becca0
    Offline

    0becca0 New Member

    Joined:
    Oct 4, 2013
    Posts:
    133
    Minecraft User:
    0becca0
    oucchhhhh :/ and kevins essentials plugin is the main one I want on myselrver and the one I love to have. hopefully kevin can get it 100 percent ported
  6. VanishedKevin
    Offline

    VanishedKevin Banned

    Joined:
    Aug 27, 2013
    Posts:
    279
    Minecraft User:
    VanishedKevin
    Yes!
  7. Glitchmaster_PE
    Offline

    Glitchmaster_PE Notable Member Plugin Developer

    Joined:
    Aug 31, 2013
    Posts:
    834
    Plugins:
    8
    Minecraft User:
    Glitchmaster_PE
    Kevin, keep in mind that 1.4 is a total re-write. So functions like: $this->api->chat->broadcast("BLAH BLAH BLAH"); and $this->api->console->run("op VanishedKevin"); will change, so be prepared
  8. VanishedKevin
    Offline

    VanishedKevin Banned

    Joined:
    Aug 27, 2013
    Posts:
    279
    Minecraft User:
    VanishedKevin
    Yo! I won't add bad code! And I will make it open source!
  9. Glitchmaster_PE
    Offline

    Glitchmaster_PE Notable Member Plugin Developer

    Joined:
    Aug 31, 2013
    Posts:
    834
    Plugins:
    8
    Minecraft User:
    Glitchmaster_PE
    I know, but just warning you that the functions will change, and I decided to tease you while I was at it ;)
  10. 0becca0
    Offline

    0becca0 New Member

    Joined:
    Oct 4, 2013
    Posts:
    133
    Minecraft User:
    0becca0
    I wont upgrade ANYTHING without your pocket essentials kevin. your plugin stays in my server as MAIN plugin. without your plugin I wont do anything else.
  11. VanishedKevin
    Offline

    VanishedKevin Banned

    Joined:
    Aug 27, 2013
    Posts:
    279
    Minecraft User:
    VanishedKevin
    Thank you so much my bro, I will make it no src change soon. :)

Share This Page

Advertisement