Advertisement
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Plugins' API (Android)

Comments in 'Plugin Development' started by Atiemeer123, May 6, 2016.

  1. Atiemeer123
    Offline

    Atiemeer123 New Member

    Joined:
    May 4, 2016
    Posts:
    3
    Minecraft User:
    PuppyDashie
    I have a problem



    [PocketMine] Server is starting...
    [PocketMine] Server was started.
    [Server] [13:18:36] [Server thread/WARNING]: Timezone could not be automatically determined. An incorrect timezone will result in incorrect timestamps on console logs. It has been set to "UTC" by default. You can change it on the php.ini file.
    [Server] [13:18:36] [Server thread/INFO]: Loading pocketmine.yml...
    [Server] [13:18:36] [Server thread/INFO]: Loading server properties...
    [Server] [13:18:36] [Server thread/INFO]: Selected English (eng) as the base language
    [Server] [13:18:36] [Server thread/INFO]: Starting Minecraft: PE server version v0.14.x alpha
    [Server] [13:18:36] [Server thread/INFO]: Starting remote control listener
    [Server] [13:18:36] [Server thread/INFO]: RCON running on 0.0.0.0:19132
    [Server] [13:18:36] [Server thread/INFO]: Opening server on 0.0.0.0:19132
    [Server] [13:18:37] [Server thread/INFO]: This server is running PocketMine-MP version 1.6dev "[REDACTED]" (API 2.0.0)
    [Server] [13:18:37] [Server thread/INFO]: PocketMine-MP is distributed under the LGPL License
    [Server] [13:18:37] [Server thread/INFO]: Loading recipes...
    [Server] [13:18:38] [Server thread/ERROR]: Could not load plugin 'Alias': Incompatible API version
    [Server] [13:18:38] [Server thread/ERROR]: Could not load plugin 'SimpleAuthHelper': Incompatible API version
    [Server] [13:18:38] [Server thread/ERROR]: Could not load plugin 'TapToDo': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'DevTools': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'EconomyAirport': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'EconomyAPI': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'EconomyAuction': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'EconomyCasino': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'EconomyJob': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'EconomyLand': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'EconomyProperty': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'EconomyPShop': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'EconomySell': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'EconomyShop': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'EconomyTax': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'EconomyUsury': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'ItemCasePE': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'iControlU': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'FactionsPro': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load '/storage/emulated/0/PocketMine/plugins/plugin-1343.phar' in folder '/storage/emulated/0/PocketMine/plugins/': phar "/storage/emulated/0/PocketMine/plugins/plugin-1343.phar" SHA1 signature could not be verified: broken signature
    [Server] [13:18:39] [Server thread/CRITICAL]: UnexpectedValueException: "phar "/storage/emulated/0/PocketMine/plugins/plugin-1343.phar" SHA1 signature could not be verified: broken signature" (EXCEPTION) in "/src/pocketmine/plugin/PharPluginLoader" at line 85
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'Rainbow_Effect': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'Slapper': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'EssentialsPE': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'BasicHUD': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'MineReset': Incompatible API version
    [Server] [13:18:39] [Server thread/ERROR]: Could not load plugin 'WorldEditArt': Incompatible API version
    [Server] [13:18:39] [Server thread/INFO]: Loading PurePerms v1.3.7
    [Server] [13:18:39] [Server thread/NOTICE]: PurePerms by 64FF00 & ProjectInfinity! #LEET.CC
    [Server]
    [Server] 888 888 .d8888b. d8888 8888888888 8888888888 .d8888b. .d8888b.
    [Server] 888 888 d88P Y88b d8P888 888 888 d88P Y88b d88P Y88b
    [Server] 888888888888 888 d8P 888 888 888 888 888 888 888
    [Server] 888 888 888d888b. d8P 888 8888888 8888888 888 888 888 888
    [Server] 888 888 888P "Y88b d88 888 888 888 888 888 888 888
    [Server] 888888888888 888 888 8888888888 888 888 888 888 888 888
    [Server] 888 888 Y88b d88P 888 888 888 Y88b d88P Y88b d88P
    [Server] 888 888 "Y8888P" 888 888 888 "Y8888P" "Y8888P"
    [Server]
    [Server] [13:18:39] [Server thread/INFO]: [PurePerms] Setting default language to 'en'
    [Server] [13:18:39] [Server thread/NOTICE]: [PurePerms] Multiworld support is currently disabled.
    [Server] [13:18:39] [Server thread/NOTICE]: [PurePerms] Don't forget to set enable-multiworld-perms option in config.yml to true if you want to use per-world permissions!
    [Server] [13:18:39] [Server thread/INFO]: Loading iProtector v3.1b
    [Server] [13:18:39] [Server thread/INFO]: Loading PeacefulSpawn v2.5
    [Server] [13:18:39] [Server thread/INFO]: Loading PureChat v1.4.0
    [Server] [13:18:44] [Server thread/INFO]: ----- PocketMine-MP Auto Updater -----
    [Server] [13:18:44] [Server thread/INFO]: It appears you're running a Beta build, when you've specified that you prefer to run Stable builds.
    [Server] [13:18:44] [Server thread/INFO]: If you would like to be kept informed about new Beta or Development builds, it is recommended that you change 'preferred-channel' in your pocketmine.yml to 'beta' or 'development'.
    [Server] [13:18:44] [Server thread/INFO]: ----- -------------------------- -----
    [Server] [13:18:44] [Server thread/INFO]: Preparing level "world"
    [Server] [13:18:44] [Server thread/INFO]: Enabling PurePerms v1.3.7
    [Server] [13:18:44] [Server thread/NOTICE]: [PurePerms] Set data provider to YAMLv1.
    [Server] [13:18:44] [Server thread/CRITICAL]: RuntimeException: "No groups found, I guess there's definitely something wrong with your data provider... *cough cough*" (EXCEPTION) in "/plugin-862.phar/src/_64FF00/PurePerms/PurePerms" at line 679
    [Server] [13:18:44] [Server thread/INFO]: Disabling PurePerms v1.3.7
    [Server] [13:18:44] [Server thread/INFO]: Enabling iProtector v3.1b
    [Server] [13:18:44] [Server thread/INFO]: Enabling PeacefulSpawn v2.5
    [Server] [13:18:44] [Server thread/INFO]: Enabling PureChat v1.4.0
    [Server] [13:18:44] [Server thread/NOTICE]: [PureChat] No valid factions plugin in default-factions-plugin node was found. Disabling factions plugin support.
    [Server] [13:18:47] [Server thread/INFO]: Starting GS4 status listener
    [Server] [13:18:47] [Server thread/INFO]: Setting query port to 19132
    [Server] [13:18:47] [Server thread/INFO]: Query running on 0.0.0.0:19132
    [Server] [13:18:48] [Server thread/INFO]: Default game type: Survival Mode
    [Server] [13:18:48] [Server thread/INFO]: Done (17.144s)! For help, type "help" or "?"


    Plzzz help... I want the plugins' author UPDATE it on android:(
  2. ImagicalGamer
    Offline

    ImagicalGamer Active Member

    Joined:
    Feb 25, 2016
    Posts:
    141
    Minecraft User:
    ImagicalGamer
    Same thing for me but they still enable.
  3. Atiemeer123
    Offline

    Atiemeer123 New Member

    Joined:
    May 4, 2016
    Posts:
    3
    Minecraft User:
    PuppyDashie
    Only some plugins work
  4. minebuilder0110
    Offline

    minebuilder0110 Notable Member

    Joined:
    Dec 8, 2014
    Posts:
    485
    Minecraft User:
    Apparitional
    Bump API.
    pmt.mcpe.me/api2
    applqpak likes this.
  5. Atiemeer123
    Offline

    Atiemeer123 New Member

    Joined:
    May 4, 2016
    Posts:
    3
    Minecraft User:
    PuppyDashie
    Pocketmine-MP for Android... Im using that and I don't want to use PC for all of the codes and files that needs to be changed.
  6. applqpak
    Offline

    applqpak Active Member Plugin Developer

    Joined:
    Dec 16, 2015
    Posts:
    284
    Plugins:
    1
    Minecraft User:
    applqpak
    Remember, you need PHP7 for a compatible version of PocketMine for MCPE v0.14.2.
    ImagicalGamer and Primus like this.
  7. MyNameIsTriXz
    Offline

    MyNameIsTriXz Notable Member

    Joined:
    Aug 17, 2015
    Posts:
    538
    Minecraft User:
    MyNameIsTriXz
    Yeah, therefore you have to modify the PocketMine APJ0K

Share This Page

Advertisement