Advertisement
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

In need help to my plugins

Comments in 'Plugin Development' started by PolskiTHEPLAYER, Dec 6, 2016.

  1. PolskiTHEPLAYER
    Offline

    PolskiTHEPLAYER New Member

    Joined:
    Apr 1, 2015
    Posts:
    55
    Minecraft User:
    Flsmers
    Hay, i write plagin on kits.

    Well, my plugin has crashed and not loade class kits.

    Code crash:
    Screen have crash:
    PHP:
        private function loadKits(){
            
    $this->saveResource("kits.yml");
            
    $kitsData yaml_parse_file($this->getDataFolder()."kits.yml");
            
    $this->fixConfig($kitsData);
            foreach(
    $kitsData as $kitName => $kitData){
                
    $this->kits[$kitName] = new Kit($this$kitData$kitName);
            }
        }

        private function 
    fixConfig(&$config){
            foreach(
    $config as $name => $kit){
                if(isset(
    $kit["users"])){
                    
    $users array_map("strtolower"$kit["users"]);
                    
    $config[$name]["users"] = $users;
                }

    Attached Files:

  2. EdwardAllington
    Offline

    EdwardAllington Active Member

    Joined:
    Jan 29, 2015
    Posts:
    78
    Minecraft User:
    Edwardthedog2
    You'll get better help on the new forums at http://forums.pmmp.io
    As for your problem, I see a message saying that the nether is being loaded. Are you sure you're using PocketMine?
    HimbeersaftLP likes this.

Share This Page

Advertisement