Advertisement
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Inactive FireworkEvents 0.2

An extension plugin of Fireworks

  1. hoyinm14mc
    Offline

    hoyinm14mc Notable Member Plugin Developer

    Joined:
    Jun 4, 2014
    Posts:
    502
    Plugins:
    9
    Minecraft User:
    hoyinm14mc
    hoyinm14mc submitted a new plugin:

    FireworkEvents - An extension plugin of Fireworks

    Read more about this plugin...
  2. Falk
    Offline

    Falk Staff Member Global Moderator

    Joined:
    Sep 2, 2013
    Posts:
    1,707
    Plugins:
    22
    Minecraft User:
    Falkirknh
    If you want your plugin to depend on another plugin, you don't need to write any code to enforce the dependency. All you need to do is add the following to your plugin.yml
    Code:
    depend: ["Fireworks"]
    hoyinm14mc, EvolSoft and PEMapModder like this.
  3. EvolSoft
    Offline

    EvolSoft Notable Member Plugin Developer

    Joined:
    Sep 10, 2014
    Posts:
    821
    Plugins:
    15
    Minecraft User:
    Flavius12
    hoyinm14mc and TonyDroidd like this.
  4. rvachvg
    Offline

    rvachvg New Member

    Joined:
    Nov 10, 2014
    Posts:
    48
    Minecraft User:
    Vitya
    Update for the new API, please !
  5. hoyinm14mc
    Offline

    hoyinm14mc Notable Member Plugin Developer

    Joined:
    Jun 4, 2014
    Posts:
    502
    Plugins:
    9
    Minecraft User:
    hoyinm14mc
    It's compatible for the newest API. Please tell the plugin developer of 'Fireworks' to update the plugin to the newest API.
  6. rvachvg
    Offline

    rvachvg New Member

    Joined:
    Nov 10, 2014
    Posts:
    48
    Minecraft User:
    Vitya
    I've already said.
  7. rvachvg
    Offline

    rvachvg New Member

    Joined:
    Nov 10, 2014
    Posts:
    48
    Minecraft User:
    Vitya
    Just look:
    Code:
    [CRITICAL] "Could not pass event 'pocketmine\event\player\PlayerLoginEvent' to 'FireworkEvents v1.0.0': Argument 1 passed to pocketmine\utils\Binary::writeMetadata() must be of the type array, null given, called in phar://D:/programs/PocketMine-MP/2/PocketMine-MP.phar/src/pocketmine/network/protocol/AddEntityPacket.php on line 72 and defined on hoyinm\FireworkEvents\Main
    [NOTICE] InvalidArgumentException: "Argument 1 passed to pocketmine\utils\Binary::writeMetadata() must be of the type array, null given, called in phar://D:/programs/PocketMine-MP/2/PocketMine-MP.phar/src/pocketmine/network/protocol/AddEntityPacket.php on line 72 and defined" (E_RECOVERABLE_ERROR) in "/src/pocketmine/utils/Binary" at line 84
    
  8. hoyinm14mc
    Offline

    hoyinm14mc Notable Member Plugin Developer

    Joined:
    Jun 4, 2014
    Posts:
    502
    Plugins:
    9
    Minecraft User:
    hoyinm14mc
    Oh..
    I'll fix it as soon as possible~
  9. hoyinm14mc
    Offline

    hoyinm14mc Notable Member Plugin Developer

    Joined:
    Jun 4, 2014
    Posts:
    502
    Plugins:
    9
    Minecraft User:
    hoyinm14mc
    TonyDroidd likes this.
  10. hoyinm14mc
    Offline

    hoyinm14mc Notable Member Plugin Developer

    Joined:
    Jun 4, 2014
    Posts:
    502
    Plugins:
    9
    Minecraft User:
    hoyinm14mc

Share This Page

Advertisement