Advertisement
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Deny permissions

Comments in 'Plugin Development' started by xFlare, Mar 8, 2015.

  1. xFlare
    Offline

    xFlare Active Member Plugin Developer

    Joined:
    Sep 28, 2014
    Posts:
    199
    Plugins:
    1
    Minecraft User:
    xFlare
    My auth plugin works well at protecting the server, it stops all commands from being used when not logged in, disabled block place/break and other nasty things player can do.

    Though there one thing I dont know how to disable. If someone logs into an op account and the plugin BanHammer is installed, the not logged in people can still ban the players with BanHammer. This is because I don't know how to set all player permission to false.

    So, how can I make it so players have no permission at all?
    LDX likes this.
  2. Gamecrafter
    Offline

    Gamecrafter

    Joined:
    Nov 20, 2014
    Posts:
    978
    Plugins:
    9
    Set all the permissions to false. All permissions will be ineffective.
  3. xFlare
    Offline

    xFlare Active Member Plugin Developer

    Joined:
    Sep 28, 2014
    Posts:
    199
    Plugins:
    1
    Minecraft User:
    xFlare
    Thats what I'm asking how to do. -.-#
    Last edited: Mar 9, 2015
    PEMapModder, iJoshuaHD and LDX like this.
  4. iJoshuaHD
    Offline

    iJoshuaHD Notable Member Plugin Developer

    Joined:
    Nov 7, 2013
    Posts:
    1,167
    Plugins:
    4
    Minecraft User:
    iJoshuaHD
    lol. what perm plugin are u using?
  5. xFlare
    Offline

    xFlare Active Member Plugin Developer

    Joined:
    Sep 28, 2014
    Posts:
    199
    Plugins:
    1
    Minecraft User:
    xFlare
    None. FlareHub uses a core plugin that controls almost everything even auth. AntiHacks is it's own seperate plugin so I can work on it until it's better. TapToDo by falk is being use for a little bit because it makes it easier to add join signs.
    LDX likes this.
  6. iJoshuaHD
    Offline

    iJoshuaHD Notable Member Plugin Developer

    Joined:
    Nov 7, 2013
    Posts:
    1,167
    Plugins:
    4
    Minecraft User:
    iJoshuaHD
    Just set permissionsAttachment of the.node to false. Look at PurePerms source for examples.
  7. PEMapModder
    Offline

    PEMapModder Notable Member Plugin Developer

    Joined:
    Oct 9, 2013
    Posts:
    7,294
    Plugins:
    11
    Minecraft User:
    PEMapModder
    Maybe get the permissions he is subscribing to from PluginManager, foreach it and set to false from your own permissionattachment.
    xFlare and iJoshuaHD like this.
  8. xFlare
    Offline

    xFlare Active Member Plugin Developer

    Joined:
    Sep 28, 2014
    Posts:
    199
    Plugins:
    1
    Minecraft User:
    xFlare
    I'll try it, simple auth does a good job at setting permissions to false too.
    LDX likes this.
  9. PEMapModder
    Offline

    PEMapModder Notable Member Plugin Developer

    Joined:
    Oct 9, 2013
    Posts:
    7,294
    Plugins:
    11
    Minecraft User:
    PEMapModder
    I don't think you need to call clearPermissions().
    LDX likes this.
  10. xFlare
    Offline

    xFlare Active Member Plugin Developer

    Joined:
    Sep 28, 2014
    Posts:
    199
    Plugins:
    1
    Minecraft User:
    xFlare
    Wait-

    Could this be a possible reason of why /login dose not work on SimpleAuth? Blocking it's own permissions?
    iJoshuaHD, PixelGuy75 and LDX like this.
  11. iJoshuaHD
    Offline

    iJoshuaHD Notable Member Plugin Developer

    Joined:
    Nov 7, 2013
    Posts:
    1,167
    Plugins:
    4
    Minecraft User:
    iJoshuaHD
    Thats why SimpleAuth + A permission manager plugin is a bad idea.

Share This Page

Advertisement