Advertisement
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AutoUpdater v1.1

Update PocketMine automatically

  1. Thunder33345
    Offline

    Thunder33345 Notable Member

    Joined:
    Apr 3, 2014
    Posts:
    755
    Minecraft User:
    Thunder33345
  2. EvolSoft
    Offline

    EvolSoft Notable Member Plugin Developer

    Joined:
    Sep 10, 2014
    Posts:
    821
    Plugins:
    15
    Minecraft User:
    Flavius12
  3. Thunder33345
    Offline

    Thunder33345 Notable Member

    Joined:
    Apr 3, 2014
    Posts:
    755
    Minecraft User:
    Thunder33345
    DUC like noip.me ones?
  4. EvolSoft
    Offline

    EvolSoft Notable Member Plugin Developer

    Joined:
    Sep 10, 2014
    Posts:
    821
    Plugins:
    15
    Minecraft User:
    Flavius12
    I'll rewrite it from scratch. I'll use a hosting company anyway.
  5. thebigsmileXD
    Offline

    thebigsmileXD Banned

    Joined:
    May 19, 2015
    Posts:
    845
    Plugins:
    1
    Minecraft User:
    XenialDan
    It just told me
    "Failed to update"
    in the config i said enabled to false, also.. is there even a new stable version out?
  6. EvolSoft
    Offline

    EvolSoft Notable Member Plugin Developer

    Joined:
    Sep 10, 2014
    Posts:
    821
    Plugins:
    15
    Minecraft User:
    Flavius12
    This plugin uses a PocketMine Web API to get the latest releases. If you are running pocketmine 1.6 it may not work because the PocketMine Web API may have not been updated
  7. thebigsmileXD
    Offline

    thebigsmileXD Banned

    Joined:
    May 19, 2015
    Posts:
    845
    Plugins:
    1
    Minecraft User:
    XenialDan
    Okay. But i use 1.5, why does it even check if i set the value in the config to false?
  8. EvolSoft
    Offline

    EvolSoft Notable Member Plugin Developer

    Joined:
    Sep 10, 2014
    Posts:
    821
    Plugins:
    15
    Minecraft User:
    Flavius12
    Where in the configuration? Can you post your config.yml?
  9. thebigsmileXD
    Offline

    thebigsmileXD Banned

    Joined:
    May 19, 2015
    Posts:
    845
    Plugins:
    1
    Minecraft User:
    XenialDan
    xD
    Wellll..... 17/03/2015? Bit wrong.
    Code:
    ---
    update-check-time: 60
    auto-update: false
    timeout: 10
    channel: "Stable"
    file-name: "PocketMine-MP.phar"
    start-script: "start.cmd"
    ...
    
  10. EvolSoft
    Offline

    EvolSoft Notable Member Plugin Developer

    Joined:
    Sep 10, 2014
    Posts:
    821
    Plugins:
    15
    Minecraft User:
    Flavius12
    Sorry but if you don't enable auto-update how can you update the server automatically!?
  11. thebigsmileXD
    Offline

    thebigsmileXD Banned

    Joined:
    May 19, 2015
    Posts:
    845
    Plugins:
    1
    Minecraft User:
    XenialDan
    There i said i set it to false because i currently don't want it to update my pocketmine. Why do i still get messages? Why does it even test for updates?
  12. EvolSoft
    Offline

    EvolSoft Notable Member Plugin Developer

    Joined:
    Sep 10, 2014
    Posts:
    821
    Plugins:
    15
    Minecraft User:
    Flavius12
    Maybe the PocketMine WebAPI is not available anymore
    thebigsmileXD likes this.
  13. Gamecrafter
    Offline

    Gamecrafter

    Joined:
    Nov 20, 2014
    Posts:
    978
    Plugins:
    9
    What are you supposed to put for "start-script" in the config file? Is it supposed to be a command line(based on the code I've seen) or just the name of the startup file?
  14. EvolSoft
    Offline

    EvolSoft Notable Member Plugin Developer

    Joined:
    Sep 10, 2014
    Posts:
    821
    Plugins:
    15
    Minecraft User:
    Flavius12
    It's the name of the startup script which is used to restart the server after the update
  15. Gamecrafter
    Offline

    Gamecrafter

    Joined:
    Nov 20, 2014
    Posts:
    978
    Plugins:
    9
    Do you have to put the full path or just the filename? For example, is start.cmd/start.sh considered a "start script"?
  16. EvolSoft
    Offline

    EvolSoft Notable Member Plugin Developer

    Joined:
    Sep 10, 2014
    Posts:
    821
    Plugins:
    15
    Minecraft User:
    Flavius12
    Only the start script name
  17. bkangels
    Offline

    bkangels New Member

    Joined:
    May 19, 2016
    Posts:
    1
    Minecraft User:
    bkangels
    ok so i downloaded it and im running pocketmine 1.6.63 and i want to update to the new API for Minecraft PE witch is Minecraft PE 0.15.0 and it says updating pocketmine and when its done it stops my server plz help

Share This Page

Advertisement