Advertisement
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Announcement Upcoming changes in API and PHP7

Comments in 'PocketMine News' started by shoghicp, Jul 22, 2015.

Thread Status:
Not open for further replies.
  1. JordanFisher2000
    Offline

    JordanFisher2000 New Member

    Joined:
    Sep 20, 2015
    Posts:
    3
    Minecraft User:
    JordanFisher_YT
    When will 2.0.0 be released?
  2. Gamecrafter
    Offline

    Gamecrafter Notable Member Plugin Developer

    Joined:
    Nov 20, 2014
    Posts:
    981
    Plugins:
    9
    It's already "released".
  3. JordanFisher2000
    Offline

    JordanFisher2000 New Member

    Joined:
    Sep 20, 2015
    Posts:
    3
    Minecraft User:
    JordanFisher_YT
    How do u download it
  4. Gamecrafter
    Offline

    Gamecrafter Notable Member Plugin Developer

    Joined:
    Nov 20, 2014
    Posts:
    981
    Plugins:
    9
  5. JordanFisher2000
    Offline

    JordanFisher2000 New Member

    Joined:
    Sep 20, 2015
    Posts:
    3
    Minecraft User:
    JordanFisher_YT
    PlayFriik likes this.
  6. M4nt0s
    Offline

    M4nt0s Active Member

    Joined:
    Sep 15, 2015
    Posts:
    49
    Minecraft User:
    M4nt0s
    How long it will need to relased 0.12.1?

    I need it for my Server.
  7. m4f1050
    Offline

    m4f1050 New Member

    Joined:
    Sep 27, 2015
    Posts:
    2
    Minecraft User:
    m4f1050
    Does anybody have a php folder (PHP7) for Pocket-Mine_PE? It seems to have 5.6.4?
  8. PocketKiller
    Offline

    PocketKiller Notable Member

    Joined:
    Jul 20, 2015
    Posts:
    741
    PHP7 isn't even ready,and it's unstable, it has Development builds, and @shoghicp already said that he started translating one of PHP7 development builds to work with PocketMine 1.6. so.. you must wait, or else go help him :p

    and you don't need to blame him, he is doing all that just for us! so you should thank him instead :D
  9. m4f1050
    Offline

    m4f1050 New Member

    Joined:
    Sep 27, 2015
    Posts:
    2
    Minecraft User:
    m4f1050
    No blame, only that releases #36 and #37 require PHP7, just wonder how others were using them... I'm still on 1.6dev-35
  10. PocketKiller
    Offline

    PocketKiller Notable Member

    Joined:
    Jul 20, 2015
    Posts:
    741
    No-One uses them :p
    TheKofola12 likes this.
  11. TheDeibo
    Offline

    TheDeibo Notable Member Plugin Developer

    Joined:
    Sep 8, 2014
    Posts:
    692
    Plugins:
    1
    Minecraft User:
    TheDeibo
    I've noticed that quite a few people have been having trouble finding an update. Well Ill kindly repeat, and explain how to update your server successfully ( With Jenkins )

    I am going to act like no one here ( who wants to update ) knows how to update all together.

    1. Go on jenkins.pocketmine.net/job/PocketMine-MP-Bleeding/
    2. Click a #(number). -- I use #35 at the moment
    3. make sure at the bottom of the page it says "origin/mcpe-0.12"
    4. click something that looks like this
      "PocketMine-MP_1.6dev-35_mcpe-0.12_a7e5e33d_API-1.13.0.phar" (((but it may be different if not #35)))
    5. Move it to your PocketMine-MP folder.
    6. remove or rename the previous Pocketmine-MP.phar
    7. Rename your new file "PocketMine-MP.phar"
    8. enjoy your server
    If you have followed the steps correctly, you should correctly updated your Server.
    If not, then we ( Me and the anyone else ) will try and help you.
    :)

    Hope it helps,
    TheDeibo
    Last edited: Sep 29, 2015
    remote_vase likes this.
  12. Krow
    Offline

    Krow New Member

    Joined:
    Sep 16, 2015
    Posts:
    3
    Minecraft User:
    Krow
    Well its next month and past. Id like to know a more stable version is coming soon. Paying to use this service and cant even play it. Just would like to know the progress prehaps an eta on release since
    0.12.1. Has been out about a month
  13. zombie_Power
    Offline

    zombie_Power Active Member

    Joined:
    Sep 7, 2015
    Posts:
    239
    Minecraft User:
    Zombie_Power
    Pocketmine is free to use
    remote_vase and Junhua like this.
  14. Krow
    Offline

    Krow New Member

    Joined:
    Sep 16, 2015
    Posts:
    3
    Minecraft User:
    Krow
    Youre right. It is free for someone who knows what theyre doing. I on the other needed to resort to a server site. Minespan to basically swrllet mine up. But still doesn't have a stable .12.1 yet. I just would like to know of anything new. New updates or an eta? The beta server i have well. ....sucks. way to many bugs to count
  15. mortaine
    Offline

    mortaine New Member

    Joined:
    Sep 30, 2015
    Posts:
    1
    Minecraft User:
    stephanie
    TheDeibo: When I try to follow your instructions for build #35, my server (Ubuntu with php 5.6), it says that it needs pthreads and to run the installer script from the homepage.
  16. JordanFisher200
    Offline

    JordanFisher200 New Member

    Joined:
    Sep 7, 2015
    Posts:
    1
    Minecraft User:
    JordanFisher_YT
    its been around 3 months since you last posted this. Why is php7 taking so long? I really wanna play your 0.12.1 MCPE serverr?
  17. TheMaks
    Offline

    TheMaks Active Member

    Joined:
    Jul 19, 2015
    Posts:
    58
    Minecraft User:
    TheMaks
    Give me please compiler for php7
  18. k3ithkfng
    Offline

    k3ithkfng Active Member

    Joined:
    Jul 9, 2015
    Posts:
    93
    Minecraft User:
    K3ith
  19. PocketKiller
    Offline

    PocketKiller Notable Member

    Joined:
    Jul 20, 2015
    Posts:
    741
    We know that, when you got a like, you spammed with that..
  20. reidq7
    Offline

    reidq7 Active Member

    Joined:
    Mar 23, 2015
    Posts:
    180
    Minecraft User:
    reidq7
    So if any devs own any of these plugins here are the ones I have... I'm going to have a hard time contacting EVERY developer and getting them to like... be active ever :p


    SimpleAuth 1.7.1; ChatDefender 1.1.1; WorldEditArt 1.0.0_beta_dev_#048; SignStatus 2.1; AdvancedKits 2.2; PopupAlerts 1.3; PurePerms 1.1.12; PeacefulSpawn 2.4; EasyMessages 1.1.0; VoteReward 2.1; MagicTelePortal 1.3.2; GrabBag 2.2.7; CustomAlerts 1.6; PrizeWin 1.0.6; DevTools 1.10.0; ManyWorlds 2.0.2; xyz 1.0.1; Slapper 1.1.1; LiveSigns 1.2.1; PocketGuard 2.1.1; essentialsTP 1.1.0; WorldProtect 2.2.0; GoldStd 1.2.2; SimpleAuthHelper 2.0.4; AlwaysSpawn 2.2.2; iProtector 3.1a; ClearLagg 1.1.0; FactionsPro 1.3.2; PureChat 1.2.9; KillRate 1.2.3


    And what is BladeStorm running on does anyone know? Their speed is legit and I want to know if its either PHP7 or something that's not pocket mine.
Thread Status:
Not open for further replies.

Share This Page

Advertisement